summaryrefslogtreecommitdiffstats
path: root/installer
diff options
context:
space:
mode:
authorramon <ramongomez@us.es>2017-06-12 09:51:20 +0000
committerramon <ramongomez@us.es>2017-06-12 09:51:20 +0000
commitdced872edd7fb7c924650ef8655d9cdb60e34a1a (patch)
tree8f0c05d12023983ee6478028550c88ae84a80d0d /installer
parentd063c011e66dd5d653a2e02cb9de356e6f539186 (diff)
#730 Instalador compatibile con CentOS 7; usar Ășltimos ogLive y actulizar tickets cerrados.
git-svn-id: https://opengnsys.es/svn/branches/version1.1@5361 a21b9725-9963-47de-94b9-378ad31fedc9
Diffstat (limited to 'installer')
-rwxr-xr-xinstaller/opengnsys_installer.sh6
-rwxr-xr-xinstaller/opengnsys_update.sh4
-rw-r--r--installer/vagrant/Vagrantfile-devel-vbox4
3 files changed, 7 insertions, 7 deletions
diff --git a/installer/opengnsys_installer.sh b/installer/opengnsys_installer.sh
index d86b4e1f..c628b140 100755
--- a/installer/opengnsys_installer.sh
+++ b/installer/opengnsys_installer.sh
@@ -188,7 +188,7 @@ case "$OSDISTRIB" in
TFTPCFGDIR=/var/lib/tftpboot
;;
fedora|centos)
- DEPENDENCIES=( subversion httpd mod_ssl php php-ldap mysql-server mysql-devel mysql-devel.i686 php-mysql dhcp tftp-server tftp xinetd binutils gcc gcc-c++ glibc-devel glibc-devel.i686 glibc-static glibc-static.i686 libstdc++ libstdc++.i686 libstdc++-devel.i686 make wget doxygen graphviz ctorrent samba samba-client rsync unzip debootstrap schroot squashfs-tools python-crypto arp-scan gettext moreutils jq )
+ DEPENDENCIES=( subversion httpd mod_ssl php php-ldap mysql-server mysql-devel mysql-devel.i686 php-mysql dhcp tftp-server tftp xinetd binutils gcc gcc-c++ glibc-devel glibc-devel.i686 glibc-static glibc-static.i686 libstdc++ libstdc++.i686 libstdc++-devel.i686 make wget net-tools doxygen graphviz ctorrent samba samba-client rsync unzip debootstrap schroot squashfs-tools python-crypto arp-scan gettext moreutils jq )
INSTALLEXTRADEPS=( 'rpm -Uv ftp://ftp.altlinux.org/pub/distributions/ALTLinux/5.1/branch/files/i586/RPMS/netpipes-4.2-alt1.i586.rpm'
'pushd /tmp; wget -t3 http://download.bittornado.com/download/BitTornado-0.3.18.tar.gz && tar xvzf BitTornado-0.3.18.tar.gz && cd BitTornado-CVS && python setup.py install && ln -fs btlaunchmany.py /usr/bin/btlaunchmany && ln -fs bttrack.py /usr/bin/bttrack; popd' )
if [ "$OSDISTRIB" == "centos" ]; then
@@ -1392,8 +1392,8 @@ function copyClientFiles()
# Crear cliente OpenGnsys.
function clientCreate()
{
- #local FILENAME=ogLive-xenial-4.4.0-34-generic-r4999.iso # 1.1.0-rc4
- local FILENAME=ogLive-xenial-4.8.0-39-generic-amd64-r5225.iso # 1.1.0-rc5
+ #local FILENAME=ogLive-precise-3.2.0-23-generic-r5159.iso # 1.1.0-rc6 (old)
+ local FILENAME=ogLive-xenial-4.8.0-39-generic-amd64-r5331.iso # 1.1.0-rc6
local TARGETFILE=$INSTALL_TARGET/lib/$FILENAME
# Descargar cliente, si es necesario.
diff --git a/installer/opengnsys_update.sh b/installer/opengnsys_update.sh
index 00f01047..fc09d496 100755
--- a/installer/opengnsys_update.sh
+++ b/installer/opengnsys_update.sh
@@ -910,8 +910,8 @@ function compileServices()
# Actualizar cliente OpenGnsys
function updateClient()
{
- #local FILENAME=ogLive-xenial-4.4.0-34-generic-r4999.iso # 1.1.0-rc4
- local FILENAME=ogLive-xenial-4.8.0-39-generic-amd64-r5225.iso # 1.1.0-rc5
+ #local FILENAME=ogLive-precise-3.2.0-23-generic-r5159.iso # 1.1.0-rc6 (old)
+ local FILENAME=ogLive-xenial-4.8.0-39-generic-amd64-r5331.iso # 1.1.0-rc6
local SOURCEFILE=$DOWNLOADURL/$FILENAME
local TARGETFILE=$(oglivecli config download-dir)/$FILENAME
local SOURCELENGTH
diff --git a/installer/vagrant/Vagrantfile-devel-vbox b/installer/vagrant/Vagrantfile-devel-vbox
index e9a0f67a..3bc352c3 100644
--- a/installer/vagrant/Vagrantfile-devel-vbox
+++ b/installer/vagrant/Vagrantfile-devel-vbox
@@ -54,9 +54,9 @@ dpkg-reconfigure -fnoninteractive console-setup
# SQL="$SQL ('ogClient0$i', '#{NETPREFIX}1$i', REPLACE('#{MACPREFIX}0$i',':',''), 1, 1, 0, 0, 0, 0, '#{NETPREFIX}1', '255.255.255.0', '00unknown', 'eth0', 'generic', 'fotoordenador.gif'),"
#done
#mysql -u usuog -ppassusuog -D ogAdmBD -e "${SQL%,}"
-#/opt/opengnsys/bin/setclientmode ogAdmin ogClient01 1
+#/opt/opengnsys/bin/setclientmode ogLiveAdmin ogClient01 PERM
#for ((i=2; i<=#{NCLIENTS}; i++)); do
-# /opt/opengnsys/bin/setclientmode ogClient ogClient0$i 1
+# /opt/opengnsys/bin/setclientmode ogLive ogClient0$i PERM
#done
# Comment out next lines to install new Angular-based web application (on early development).
#apt-get install -y git nodejs npm