summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJose M. Guisado <jguisado@soleta.eu>2021-04-19 09:26:31 +0000
committerOpenGnSys Support Team <soporte-og@soleta.eu>2021-04-20 11:27:21 +0200
commit7d74d42c79fb2747e42b4d9e2743abbc86a5354c (patch)
treef8840f79dc05a2862168231d7d6df6390462acc1 /Makefile.am
parentc2c6ce93b1feecbcc79b4d52cf68823f14e88410 (diff)
#1042 Update database schema automatically
This patch adds database schema management capabilities to ogServer: - ogServer now tracks the version of its database schema, if no version is detected, creates a 'version' table with a single row starting at 0. - ogServer can upgrade its database schema to a newer version if detected. (ogServer ships required SQL commands to do so) If ogServer is unable to upgrade the schema at startup (if needed be) it *will not* start. Defines schema update v1 which upgrades database engine tables of ogServer database (usually named 'ogAdmBD') from myISAM to innoDB.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5a38431..bf93816 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,6 +8,7 @@ ogserver_SOURCES= src/ogAdmServer.c \
src/dbi.c \
src/main.c \
src/schedule.c \
+ src/schema.c \
src/utils.c \
src/rest.c \
src/client.c \