summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorOpenGnSys Support Team <soporte-og@soleta.eu>2020-01-22 13:32:12 +0100
committerOpenGnSys Support Team <soporte-og@soleta.eu>2020-06-02 12:32:36 +0200
commit83b242ce587fa910861bb2e6b4cdf2cffd38df65 (patch)
treec6fd25d74ac98afb8101913d810ca8798dc800d7 /Makefile.am
parentaf30cc7dbbd9ee4d6ae2c93fd9ecd46975bf16a6 (diff)
#942 Add support for scheduled tasks and commands
This field needs to be at least 31 bits long to store all days in a month. Other fields are also set to 32 bits because unsigned int length can change depending on the system. We also need to support the three ways that the ogAdmAgent and the WebConsole have to create an schedule. At first, we only supported the easiest method: * Hour, day, month and year -> 10:00, 28, february, 2020 This commit adds these two ways to create an schedule: * Hour, week day, month and year -> 10:00, Monday, february, 2020 * Hour, week, month and year -> 10:00, first week, february, 2020
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 393f3e9..433cfd1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,4 +3,5 @@ sbin_PROGRAMS = ogAdmServer
AM_CFLAGS = -I../../Includes ${LIBDBI_CFLAGS} ${LIBJANSSON_CFLAGS} ${LIBEVENT_CFLAGS} -g -Wall
ogAdmServer_SOURCES= sources/ogAdmServer.c \
- sources/dbi.c
+ sources/dbi.c \
+ sources/schedule.c