summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOpenGnSys Support Team <soporte-og@soleta.eu>2019-12-10 19:21:47 +0100
committerOpenGnSys Support Team <soporte-og@soleta.eu>2020-06-02 12:32:36 +0200
commit6a0fcf96700a7b640114ea40cb64e3c3a5213a68 (patch)
tree6cfe0908f29096164721cd3066701a7992b467dc /configure.ac
parent54d172e972067e4ddcfd11c613929af811754f99 (diff)
#970 autotools support for ogAdmServer
To build and to install ogAdmServer: autoreconf -fi ./configure make make install Default prefix is /opt/opengnsys/ as usual. ogAdmServer uses autotools for compilation, so this patch adapts OpenGnsys updater and installer to use autotools for compilation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..e7014b5
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,25 @@
+AC_INIT(ogAdmServer, 1.1.1, opengnsys-devel@listas.unizar.es)
+AC_CONFIG_AUX_DIR([build-aux])
+AC_PREFIX_DEFAULT(/opt/opengnsys)
+
+AC_CANONICAL_HOST
+AC_CONFIG_MACRO_DIR([m4])
+AM_INIT_AUTOMAKE([-Wall foreign subdir-objects tar-pax no-dist-gzip dist-bzip2 1.6])
+
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LN_S
+
+case "$host" in
+*-*-linux*) ;;
+*) AC_MSG_ERROR([Linux only, sorry!]);;
+esac
+
+AC_CHECK_LIB([jansson], [json_object], , AC_MSG_ERROR([libjansson not found]))
+AC_CHECK_LIB([dbi], [dbi_initialize], , AC_MSG_ERROR([libdbi not found]))
+AC_CHECK_LIB([ev], [ev_loop_new], , AC_MSG_ERROR([libev not found]))
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT